You are here

New Feature 2.5D Navigation, SUAS MapServer 3.11.0429 beta4 released!

8 posts / 0 new
Last post
leelight
New Feature 2.5D Navigation, SUAS MapServer 3.11.0429 beta4 released!

Hi folks,
Thank you for your testing and bug reporting!
New version is released now.

Add Features:
1, 2.5D Navigation
New request name GetMap25D was added as extenstion for WMS, the map can simulate the fake 3D map with looking down angle of view. Now only supports raster image

Here is one Gif file, consisting of maps with different bbox.

You can enter 2.5D Navigation in menu WMS Extension in Demo page.

2, Mapviewer interface DIY
Now I divide Openlayers Viewer from GetMap demo page and add it to WMS Extensions. Now you can design your map views' interface, without learning the javascript API from Openlayers, just click and send request.

3, international code supporting and render text along the roads. Set define(outputTextCountry,"xx") in global.php

4,Layer's scale Denominator in SLD
Now you can set the scale for each layer in SLD defination, so that the layers can be displayed with a certain scale -- it will speed up your map rendering.

Fixed Bugs:
1. String texts were truncated by the boundary when using Openlayers viewer to browse the map. Please open global.php and set define("OverlapRatio", 0.2) to a suitable value
2. s5.php in setting displays nothing when config the setting of SUAS

TODO:
1, E00 file input
2, PostGIS database support
3, WFS: GetGmlObject, and Transaction request, user can use mapInfo WFS service to modify the data in database directly.
4, SVG map viewer client, user could interact with MapServer
5, WCS service
6, Data file backup function
7, 3D vrml or X3D map support.
8, 2.5D vector map support

The source code can be downloaded here. suas3_11_0429_beta4.zip

How to Update SUAS old version:
Please backup the config.php in SUAS and overwrite all the files.

For who has download this version before Mai.04, please download this version again, I make a mistake when I package the new version. Now I have updated this file!

Thank you!
leeight

Site: 
karabas

I installed last version, imported several mifs and created Style.
Next I tries to view map - cannot find suas/Demo/wms_GetMap.php
I looked to Demo dir - no such file. I create simlink from wms_getmap.php to wms_GetMap.php
and got empty page with white image without any html code.
I tried  all three WMS extension - the same result - empty page with empty  picture.

leelight

Hi, please delete the old php file in Demo folder in  your host, and then copy the new files inside. Because I rename some php file with same text but with different lowcase or uppercase text, if you just copy it the new file could the overwrite the old one,but the old name can not be replace with new name. If still has this problem, please clear the cache in your browser and refresh the page. Try it...

karabas

I didnot update old version. I deleted it and installed from scratch.
So what files to delete?

PS
I highly recommend to test new versions via installing from scratch.

leelight

Please download this version again, I make a mistake when I package the new version. Now I have updated it!
and I can't catch up with you, what does "installing from scratch" mean? Could you explain? thx!!!

karabas

I deleted suas dir and installed last version. Imported some mifs.
menu Getmap  still got empty image.
menu Map_Viewers works but no map displayed, only interface.
PanZoomBar incorrectly displayed - as a mix of Panzoom and PanzoomBar
I did not check where is the problem - in import or in viewer

"installing from scratch"  I mean - install as at first time on empty computer.

leelight

Thank you for your explanation!
I deleted suas dir and installed last version. Imported some mifs. menu Getmap  still got empty image.
Strange, I checked the zip file sevral times, it has no problem and I tested on a clean computer, it works. Maybe the package has problem on some computers. I am trying to publish the SUAS in sourceforge.net, the package release system there is better than here:) :lol:
menu Map_Viewers works but no map displayed, only interface.
PanZoomBar incorrectly displayed - as a mix of Panzoom and PanzoomBar
There are 2 possible reason:
1, you have set the layer scale (Display Range between Scales) in SLD setting, so the layers will be displayed between some scale, you should set the scale to a suitable value-- that is different for different coordinate system.
2, The openlayers javascript plugin in the openlayers website does not work always, sometimes you can not  use it. But now I have change it to use the library of openlayers in localhost. This will be in next version, I hope I will not have the copyright problem. :)

tom11

The information is applicable since I was able to set the scale for each layer in SLD defination. Now the layers can be displayed with a certain scale. And it has speed up your map rendering.

--- reparo de parabrisas
.

Log in to post comments